Пример интеграции MyChat и "1С: Предприятие" версий 8.xx чeрез Native API

Пример интеграции MyChat и "1С: Предприятие" версий 8.xx чeрез Native API

Тестовый пример для интеграции MyChat и 1С версии 8.3 работает по технологии NativeAPI.

 

Всего три простых шага.

 

1. Копирование DLL-библиотек

 

Нужны две DLL-библиотеки:

C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\MyChatIntegrationAPIDLLs\x32\mychat.dll — x32 библиотека MyChat Integration API

 

и

 

C:\Program Files (x86)\MyChat Server\doc\IntegrationAPI\1C\8.xx\mychatvk.dll — внешняя компонента для 1С.

 

Выкладываем обе библиотеки в \bin папку установленной 1С: в C:\Program Files (x86)\1cv8t\8.3.5.1248\bin\

 

 

2. Изменение конфигурации 1С

 

В конфигурации 1С пишем что-то в этом духе:

 

Перем КомпонентMyChat;

Процедура ПоказатьТекстСтатусаНажатие(Элемент)
   ТекстСообщения = ТекстСтатуса + Символы.CR + Символы.LF + "Вторая строка";  
                            // адрес сервера, номер порта, ключ Integration API, отправитель, получатель, текст сообщения
   Результат = КомпонентMyChat.SendPrivateMessage("your-server-ip", 2004, "iddqd", "0", "6", ТекстСообщения);
   Сообщить(Результат); // результат работы функции
КонецПроцедуры

Процедура ПриОткрытии()
   Сообщить("Версия MyChat.dll - " + КомпонентMyChat.GetMyChatLibVersion());
   Сообщить("Дата MyChat.dll - " + КомпонентMyChat.GetMyChatLibReleaseDate());
   Сообщить("Версия MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibVersion());
   Сообщить("Дата MyChatVK.dll - " + КомпонентMyChat.GetMyChatVKLibReleaseDate());
КонецПроцедуры

Результат=ПодключитьВнешнююКомпоненту("mychatvk.dll","MyChat", ТипВнешнейКомпоненты.Native);
Если Результат Тогда
   КомпонентMyChat = Новый ("AddIn.MyChat.MyChatClass");
Иначе Сообщить("Ошибка подключения mychatvk.dll!");
КонецЕсли;

 

В примере кода вместо your-server-ip следует подставить IP адрес или доменное имя вашего работающего MyChat Server.

 

 

3. Запуск конфигурации 1С и отправка сообщения в мессенджер MyChat

 

Запускаем конфигурацию и жмём кнопку (пример переделан из стандартного, в учебной версии):

 

Пример работы с компонентой MyChat в 1С 

 

Если компонент загрузился успешно, мы должны в логе увидеть вот что:

 

Компонент MyChat для 1С успешно загружен

 

Набираем текст сообщения, жмём кнопку, и в MyChat приходит уведомление:

 

Сообщение, отправленное из 1С, успешно пришло в корпоративный мессенджер MyChat

 

Сообщение успешно отправлено в корпоративный чат MyChat для пользователя с UIN 6 от имени стандартного робота Elisa (UIN 0).

 

Пожалуйста, задавайте вопросы по разработке на официальном форуме технической поддержки.

 

Ещё посмотреть

Описание функций внешней компоненты

Список ошибок MyChat IntegrationAPI